MK-AUTH

[ RESOLVIDO ] COMO ADICIONAR MAIS DE 1 SERVIDOR MK-AUTH NO MESMO MIKROTIK?

Alguém pode tirar essa duvida?

Gostaria de incluir mais de 1 servidor MK-Auth no mesmo mikrotik.

Motivo: Filiais com financeiro separado.

OBS: Ate que consegue configurar dois mk-auths, porem no momento da consulta no radius do mikrotik, só faz a consulta no primeiro radius criado.

Exibições: 1329

Responder agora

Respostas a este tópico

Oi!

Consegui aqui.

É só colocar cada Radius com o timeout diferente.

Aqui adicionei dois.

Um com timeout: 5000

E o segundo com Timeout: 9000

Se não achar no de 5000 procura no outro e assim por diante.

vlw.

Boa Noite Danilo, estou com o mesma dificuldade aqui, tinha autenticação dos clientes nas RBS das repetidoras, mas devido ao alto processamento e as RBS não estar dando mais conta, comprei uma CCR 1036 e os clientes estão todos autenticados nela agora. Como tenho 02 Mk-auth tbm devido a financeiro da filial separado não estou conseguindo fazer funcionar direito em 01 mk-auth.

Em 01 esta tudo funcionando correto porem no outro não consigo fazer funcionar SSH devido a não conseguir cadastrar 02 users mkauth no mikrotik pra importar a chave ssh e tbm não funciona o bloqueio e as paginas de corte..

Uso 90% dos clientes PPPOE...

Saberia me dizer quais procedimentos devo fazer aqui pra solucionar esses problemas. Grato!!! 

Boa tarde amigos, como não encontrei a solução em outro local resolvi postar aqui mesmo.

Como no caso do amigo Danilo, também possuo 2 cidades que tenho que separar o financeiro.

Compramos esse segundo provedor que já possui um mk-auth ativo e para organizar (sistema de boletos, clientes realmente ativos e etc.) resolvi instalar outro mk-auth, importar os clientes e na atualização cadastral dos mesmos, começar a gerar um novo carne com o nosso banco da matriz.

para isso acontecer preciso dos dois autenticando, pois assim que for atualizado o cadastro no novo e liberado os clientes ja autenticariam por ele e seriam desativados do antigo.

Fiz como indicado pelo amigo Danilo mas sem sucesso, o segundo mk-auth não recebe a solicitação como na imagem:

Alguém já fez funcionar?

É para isso que serve o parâmetro Realm do RADIUS.

Crie um RADIUS com cada Realm (domínio), um para cada MK-AUTH.

Realm "provedor1", atente os clientes com 'login@provedor1'; e assim por diante.

Então só vai funcionar se eu trocar o login de todos os clientes quando passar para o novo servidor?

Marco de Freitas disse:

É para isso que serve o parâmetro Realm do RADIUS.

Crie um RADIUS com cada Realm (domínio), um para cada MK-AUTH.

Realm "provedor1", atente os clientes com 'login@provedor1'; e assim por diante.

Nesse esquema, sim.

Felipe Salgado Gomes disse:

Então só vai funcionar se eu trocar o login de todos os clientes quando passar para o novo servidor?

amigo me add no skype pois eu fiz isso tenho um servidor mikrotik autenticando em dois mk-auth

prsoliveira2010

Bom amigo, eu acabei desistindo, limpei os títulos do antigo proprietário e alterei os dados da empresa, mas se vc realmente gostaria de ajudar a todos com seu conhecimento posta aqui mesmo a solução, pois estamos aqui para discutir abertamente sobre o sistema.

Obrigado!

P. Roberto disse:

amigo me add no skype pois eu fiz isso tenho um servidor mikrotik autenticando em dois mk-auth

prsoliveira2010

tenta assim

/ppp aaa
set interim-update=20s use-radius=yes
/system scheduler
add interval=1m name=radius on-event="/radius move number=0 destination=1;\r\
\n:delay 30s;\r\
\n/radius move number=1 destination=0" policy=ftp,reboot,read,write,policy,test start-time=startup

Boa Tarde!

estava eu procurando a solução para este problema e li em um post de alguém aqui no fórum do mk-auth sobre mudar o tempo do Timeout do servidor radius da seguinte maneira

servidor 1=Timeout 5000

servidor 2=Timeout 9000

porem também não funcionou o que eu tentei fazer é aumentar o período entre os Timeout que ficou da seguinte maneira:

servidor 1 = Timeout 300

servidor 2 = Timeout 9000

funcionou os clientes tentavam autenticar no primeiro servidor caso o radius não achasse a informação passava para o segundo servidor!

espero ter contribuído!

valeu a dica..

Maikel Pappis disse:

Boa Tarde!

estava eu procurando a solução para este problema e li em um post de alguém aqui no fórum do mk-auth sobre mudar o tempo do Timeout do servidor radius da seguinte maneira

servidor 1=Timeout 5000

servidor 2=Timeout 9000

porem também não funcionou o que eu tentei fazer é aumentar o período entre os Timeout que ficou da seguinte maneira:

servidor 1 = Timeout 300

servidor 2 = Timeout 9000

funcionou os clientes tentavam autenticar no primeiro servidor caso o radius não achasse a informação passava para o segundo servidor!

espero ter contribuído!

Responder à discussão

RSS

parcerias

© 2021   Criado por Pedro Filho.   Ativado por

Badges - Divulgar  |  Relatar erro no site  |  Termos de serviço