MK-AUTH

Antes de mais nada gostaria de dizer ao pessoal que não sou bom para fazer tutorial mas vou fazer de forma que possam entender,primeiramente você terá que adquirir um modem 3g e um mikrotik que tenha entrada usb que pode ser tanto um pc como uma routerbord com a entrada usb integrada,na escolha do modem recomendo as marcas zte de preferencia o modelo 190B e huawey (cuidado com falsificados) caso tenha duvidas consulte aqui a lista de compatíveis com mikrotik http://wiki.mikrotik.com/wiki/Supported_Hardware de posse do seu modem e mikrotik e funcionando corretamente  vamos ao passo seguinte,em controles de servidores  adicione um servidor mikrotik com nome servidor sms faça tudo como se fosse um servidor comum gere a  chave ssh crie a senha e etc...,teste a comunicação entre o mkauth e mikrotik estando tudo ok vamos ao seguinte baixe o ssh secure shell  e entre no seu mkauth,navegue nas pastas var/www e jogue a pasta sms dentro da mesma,e emseguida edite a seguinte linha de comando que pode variar de acordo com seu servidor sms por exemplo veja alinha abaixo que está dentro do php index

<?php

$celular = $_GET['to'];
$mensagem = $_GET['msg'];
shell_exec(" sudo ssh -l mkauth ip do mikrotik servidor sms -p 22 '/tool sms send usb0 " .$celular. " message=\"" .$mensagem. "\" ' ");

?>

Em ip do mikrotik servidor você colocar o ip do mikrotik que está o modem onde você configurou tudo direitinho com chave ssh e em usb0 só altere se seu modem estiver em outra porta usb no mikrotik para isso é só ir em tool sms e sem send sms você vai ver onde está seu modem,feito isto agora vem a parte mais facil vá em servidores externos sms e escolha play sms e no campo servidor coloque localhost/sms caso o mkauth não deixe você salvar por causa de usuario e senha você preencha com qualquer besteira o usuario e senha para o mesmo salvar,fazendo isso é só testar ,os arquivos estão aqui e espero ter ajudado.

Exibições: 3333

Responder agora

Respostas a este tópico

valeu...

waldemir santos gomes disse:

pronto ta ai o zip

Aqui tive problema, pois Com chip da claro só conseguia enviar diretamente pelo mikrotik. E pelo mk auth enviando o comando não funcionava. Aí resolvi trocar de operadora e coloquei Oi aí funcionou e Tim também. 

Blz , mas tem uma forma mais simples usando o SMS e NETWATCH do próprio mikrotik.

Cordialmente,
Consultor Alexsandro Soares
Analista de redes de telecomunicações
Certificação MIKROTIK  MTCNA -MTCWE - MTCRE- MTCINE
Rádios Licenciados WNI-SIAE-CERAGON

acompanhando

correto eu utilizo essa ferramenta mas para monitorar os pop queda de link entre outras coisas . mas no meu caso estava querendo fazer os dois monitorar  e ainda sim mandar sms para o cliente tipo aviso de atraso bloqueio avisos etc. via mk auth.

/tool netwatch

add comment="ROTA DA FIBRA" down-script="/tool sms send usb3 \"+5521\" message=\"ROTA DA FIBRA DOWN\"\r\
\n/tool sms send usb3 \"+5521\" message=\"ROTA DA FIBRA DOWN\"\r\
\n/tool sms send usb3 \"+5521\" message=\"ROTA DA FIBRA DOWN\"\r\
\n/tool sms send usb3 \"+5521\" message=\"ROTA DA FIBRA DOWN\"\r\
\n/tool sms send usb3 \"+5521\" message=\"ROTA DA FIBRA DOWN\"\r\
\n/tool sms send usb3 \"+5521\" message=\"ROTA DA FIBRA DOWN\"" host=gateway da rota da fibra interval=2m up-script="/\

Uma pergunta,tem que ter uma rb nova ou usa-se a mesma que já está em uso no mkauth,ou seja ,uma rb somente para servidor sms.

A routerboad basta ter porta usb ...

antonio carlos disse:

Uma pergunta,tem que ter uma rb nova ou usa-se a mesma que já está em uso no mkauth,ou seja ,uma rb somente para servidor sms.

Pedro,

Quando vai se tornar padrão no MK-AUTH? Será legal.....

RB1100AHX2 NÃO TEM ENTRADA USB

Ola Tiago,voce poderia me ajudar a utilizar esse metodo pra monitorar minha rede?

tiago costa de carvalho disse:

correto eu utilizo essa ferramenta mas para monitorar os pop queda de link entre outras coisas . mas no meu caso estava querendo fazer os dois monitorar  e ainda sim mandar sms para o cliente tipo aviso de atraso bloqueio avisos etc. via mk auth.

/tool netwatch

add comment="ROTA DA FIBRA" down-script="/tool sms send usb3 \"+5521\" message=\"ROTA DA FIBRA DOWN\"\r\
\n/tool sms send usb3 \"+5521\" message=\"ROTA DA FIBRA DOWN\"\r\
\n/tool sms send usb3 \"+5521\" message=\"ROTA DA FIBRA DOWN\"\r\
\n/tool sms send usb3 \"+5521\" message=\"ROTA DA FIBRA DOWN\"\r\
\n/tool sms send usb3 \"+5521\" message=\"ROTA DA FIBRA DOWN\"\r\
\n/tool sms send usb3 \"+5521\" message=\"ROTA DA FIBRA DOWN\"" host=gateway da rota da fibra interval=2m up-script="/\

Responder à discussão

RSS

Links

© 2021   Criado por Pedro Filho.   Ativado por

Badges - Divulgar  |  Relatar erro no site  |  Termos de serviço