Boa noite a todos , estive quebrando a cabeça devido a queda do mk auth na nuvem meus clientes ficaram sem conexão então decidi automatizar , e como consegui através de varias postagens do forum e muita tentativa e erro decidi então compartilhar com vocês 

 o que ele irá fazer ?

Todos os dias no horário que você decidir ele irá  primeiro, deletar os secrets que criou através do backup do mk, sem seguida criar novamente

isso evita que fiquem varios secrets

vai monitorar seu radius atavés de ping e quando cair

vai desativar as regras acima e ativar os secrets 

quando subir novamente vai ativar as regras acima e desativar os secrets 

 espero que ajude vocês 

system > script 

name : importar-pppoe

#===============================
:global IPMKAUTH "IP DO SEU MK AUTH";
:global KEY " SUA KEY QUE FICA LOCALIZADA NO PAINEL DO MKAUTH RADIUS";
:global RAMAL "192.168.50.217";
:global done "";
/tool fetch mode=http url="https://$IPMKAUTH/mkt/pppoe.php\?key=$KEY&ramal=$RAMAL" src-

vai salvar 

IP > Pool

vai criar duas com nome de 

Local-1

Remoto-1

(padrões do mkauth se não não importa os planos e clientes)

salvou

vai em system>scheduler e cria um com nome 

Backup_pppoe_mk

start time a hora que você quiser 

interval eu coloquei 24:00:00 (a cada 24h)

no painel coloque 

:execute script=importar-pppoe;

SALVE

pronto todo dia no horário que você escolher vai fazer o backup do seus clientes e planos .

porém se executar 2 vezes criará duplicatas então vamos sempre antes do backup deletar o backup antigo

 

crie outra em system scheduler +

name : deletar_secrets

start time : eu costumo colocar 2 a 3 min antes da regra acima 

interval time : 24h

no painel  coloque 

:execute script=limpar profile/secret;

 

Agora vamos voltar em 

system>script +

name limpar profile/secret

script

:log warning "Zerando Configurações PPPoE";
:delay 2s
/ppp profile remove [/ppp profile find where comment=mkauth]
/ppp secret remove [/ppp secret find where comment=mkauth]
:log warning "Profiles e Secrets Apagados com Sucesso";
} else={
:log error "Secrets não foram apagados ";
}

 

PRONTO TODO DIA AGORA ANTES DE REALIZAR O BACKUP ELE LIMPA O SISTEMA ,DELETA OS PLANOS E USUARIOS QUE TEM O COMENTÁRIO "MKAUTH"

APÓS DELETAR EM 2 OU 3 MINUTOS DEPOIS ELE REALIZA UM NOVO BACKUP DO MK-AUTH 

OU SEJA OS ASSINANTES QUE VOCÊ CADASTROU NAQUELE DIA VÃO PARA O SECRETS

Agora iremos fazer com que , quando o seu mk-auth que esta na nuvem ficar fora do ar 

o seu mikrotik vai 

ativar os clientes secrets com comentário "mkauth"

desativar as regras de deletar e de backup automatico (porque desativar? se seu mk esta fora do ar quando o seu mikrotik deletar os secrets e planos ele não vai ter como puxar de volta)

e quando seu mkauth retornar seu mikrotik vai

desativar os clientes do secrets 

ativar as regras de deletar e backup automatico

 

Vamos em 

System> Script > + 

name: MK-AUTH_ATIVO

painel:

ppp secret set [/ppp secret find comment =mkauth] disabled=yes

Salve

Crie mais um 

name : MK-AUTH_INATIVO

painel :

ppp secret set [/ppp secret find comment =mkauth] disabled=no

Salve

/\ esses dois scripts são responsaveis por ativar e desativar seus Secrets do backup

 

Vai em 

Tools> Netwatch > +

Host : IP DO SEU MK AUTH (que fica em RADIUS)

Interval: 00:00:01 (1segundos para você testar tudo depois que ver que esta ok pode mudar para 10s ou 30s quanto quiser )

timeout: 300ms

muda para a aba UP

painel

log
:log info message="MK-Auth Está ONLINE"
:log info message="Clientes de Base Local estão DESATIVADOS"
/system script run MK-AUTH_ATIVO
/system scheduler enable Backup_pppoe_mk
/system scheduler enable deletar_secrets

mude para a aba Down

:log info message="MK-Auth Está OFFLINE"
:log info message="Clientes de Base Local estão ATIVOS"
/system script run MK-AUTH_INATIVO
/system scheduler disable Backup_pppoe_mk
/system scheduler disable deletar_secrets

 

Pronto, /\ o netwatch fica pingando para seu mk-auth quando não consegue pingar ele realiza tudo automatico

mk on> desativa secrets, ativa deletar automatico ativa backup automatico

mk off> ativa secrets , desativa deletar automatico , desativa backup automatico

 

Seguindo nesta ordem não tem erro, espero ter ajudado alguém, desculpe pelo tópico grand ^_^'

Para adicionar comentários, você deve ser membro de MK-AUTH.

Join MK-AUTH

Enviar-me um email quando as pessoas responderem –