MK-AUTH

Pedro e quem puder me ajudar.

 

Estou com o seguinte problema. Uso pppoe  com radius e Tenho essas regras adicionar em meus mikrotik para pg corte:

 

/ip firewall nat

 

add action=dst-nat chain=dstnat comment="PG CORTE PPPOE" disabled=no \

    dst-port=0-65535 protocol=tcp src-address-list=pgcorte to-addresses=\

    172.31.255.2 to-ports=85

add action=dst-nat chain=dstnat comment="PG CORTE" disabled=no dst-address=\

    !172.31.255.2 protocol=tcp src-address=10.3.0.2-10.3.3.255 to-addresses=\

    172.31.255.2 to-ports=85

 

Ocorre que da versão 4.94 para cá, não esta mais bloqueando meu clientes automaticamente. Alguém poderia me ajudar?

Exibições: 1281

Responder agora

Respostas a este tópico

o cliente fica em vermelho ?? se não ver se a data do mk-auth esta correta...

Sim Pedro, fica vermelho! Quanto a data ainda não verifiquei, mais vou fazer isso e te posiciono!

Aparentemente a data esta correta. Veja se confere abaixo:

root@GCTelecom:~# date
Wed Mar 20 08:32:57 AMT 2013
root@GCTelecom:~#

então o sistema esta bloqueando, o problema é na configuração da pagina de corte, se vc usa a pagina de corte por radius, uma forma de vc saber se seu cliente realmente esta bloqueado no radius e clica no link informações que tem abaixo do nome do cliente e na janela que abre na parte de radius veja se tem os parametros Mikrotik-Mark-Id ou Framed-Pool (clientes hotspot) ou Mikrotik-Address-List (clientes pppoe) como na imagem abaixo, se tem então o erro com certeza é no mikrotik por isso depois do login, veja se o cliente bloqueado aparece no mangle do mikrotik (hotspot) ou veja se o ip do cliente bloqueado entra no address-list do mikrotik (pppoe):

 

 

se vc usa a pagina de corte por ssh, uma forma de vc saber se seu cliente realmente esta bloqueado é ver se na address-list o ip do cliente aparece, se não aparece veja se não é falha na comunicação ssh, clique no link informações da pagina de ramais mikrotik e veja se aparece os dados como na imagem abaixo, caso os dados sejam mostrados com sucesso então a razão do bloqueio por ssh não funcionar é pq o cliente não tem um ip definido no cadastro dele ou nunca tenha se conectado ao provedor.

 

 

nas duas formas de bloqueio é preciso colocar a regra de redirecionamento para pagina de corte acima da regra de nat para o proxy no nat do mikrotik e nas configurações de profile de hotspot do mikrotik é preciso deixar a opção transparet proxy desativada.

 

veja abaixo as regras atuais para exibir a pagina de corte com radius ou ssh:

 

Para todos os clientes:

/ip firewall nat

add action=dst-nat dst-address=!172.31.255.2 chain=dstnat comment="PG CORTE" disabled=no protocol=tcp src-address-list=pgcorte to-addresses=172.31.255.2 to-ports=85

Para hotspot com radius (pool):

/ip pool

add name=pgcorte ranges=10.3.0.2-10.3.3.254

/ip address

add address=10.3.0.1/22 broadcast=10.3.3.255 network=10.3.0.0 interface=Placa do clientes

/ip firewall nat

add action=dst-nat dst-address=!172.31.255.2 chain=dstnat comment="PG CORTE" disabled=no protocol=tcp src-address=10.3.0.2-10.3.3.254 to-addresses=172.31.255.2 to-ports=85

Para hotspot com radius (mangle):

/ip firewall mangle

add chain=prerouting action=jump comment="PG CORTE" jump-target=hotspot

/ip firewall nat

add chain=hotspot comment="PG CORTE" packet-mark=bloqueado protocol=tcp action=dst-nat to-addresses=172.31.255.2 to-ports=85

GCTELECOM disse:

Sim Pedro, fica vermelho! Quanto a data ainda não verifiquei, mais vou fazer isso e te posiciono!

Pedro eu uso somente pppoe, neste caso, ha necessidade de apenas esta regra no mikrotik?

/ip firewall nat

add action=dst-nat dst-address=!172.31.255.2 chain=dstnat comment="PG CORTE" disabled=no protocol=tcp src-address-list=pgcorte to-addresses=172.31.255.2 to-ports=85

Com isso funcionará tambem a página de corte?

A minha também está sem funcionar, a hora está correta, dentro do mk-auth o cliente fica vermelho, mais lá no adress list dentro do firewall no mikrotik, não aparece ninguém. 

Responder à discussão

RSS

Links

© 2021   Criado por Pedro Filho.   Ativado por

Badges - Divulgar  |  Relatar erro no site  |  Termos de serviço