MK-AUTH

Como deixar a pagina de manutenção automática!

         Gosto de trabalhar muito com mikrotik principalmente com regras de firewall e script, passei pra poucas pessoas algumas coisas que sei, (toda semana vou estar postando regras funcional) claro que mikrotik cada vez mais você estuda mais você sabe que não sabe, tipo a bíblia cada vez que você ler mais você aprende e quando volta no mesmo assunto você descobre mais assim e o mikrotik. atualmente faço manutenções pra alguns provedores porte médio alto, só que quero estar passando um pouco a cada tempo do que seu sei ei estar ai as regras bem fácil de automatizar sua pagina de bloqueio sem bug.

          1ª a regra do nat todos já conhece ai estar ela só colocar o ip do seu MK-Auth, para melhor aproveitamento coloca regra do nat no topo.

           copie a regra para um bloco de nota coloca o ip do mk-auth depos copie no terminal do mikrotik. pronto ( NO SRC-ADDRESS= coloca o ip do seu mk-auth e o ! antes pra nao valer a regra pra ele)

/ip firewall nat
add action=dst-nat chain=dstnat comment="=====================================\
    ====Manutencao-cleber-Mk-auth========================================" \
    disabled=yes dst-port=80 priority=1 protocol=tcp src-address=! IP-DO SERVIDOR MK-AUTH \
    to-addresses=IP-MK-AUTH to-ports=89

          2ª já estou mandando a regra do script prontinha pra você colar direto no terminal do seu mikrotik. Ctrl-c , Ctrl-V.

        a sim antes pra você saber mais sobre a regra abaixo, ela manda 20 pins pro dns da google caso falha os 20 pings em seguida ela ativa a regra do nat, assim faz que direcione pra pagina de manutenção, quando NORMALIZAR os pings a mesma regra desativa o comando de manutenção e tudo volta como era.

 

/system script

add name=Manutencao-cleber policy=\
    ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive source=":\
    local i [ping 8.8.8.8 count=20]; :if (\$i = 0) do={/ip firewall nat enable \
    [find comment=\"=========================================Manutencao-cleber-\
    Mk-auth========================================\"];} else={/ip firewall nat\
    \_disable [find comment=\"=========================================Manutenc\
    ao-cleber-Mk-auth========================================\"];};"

 

              3ª para todos os scripts precisamos de scheduler, essa regra também é só copiar e colar direto no terminal do mikrotik, ela manda o comando para o script de 2 em 2 minutos sem da LOG no seu sistema, faz em silêncio.

/system scheduler

add interval=2m name=Manutencao-cleber on-event=Manutencao-cleber policy=ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive start-date=jan/01/1970 \
    start-time=00:00:00

 

OBS: essas regras fiz na versão 6X do mikrotik, pela minha teoria eh só terá a prioridade da regra do nat acima que funciona na versão 4 e 5X.

 

Quem entende um pouco de regras de mikrotik, pode mudar alguns detalhe de ex: o comentário.

 

curti no facebook: sosprovedor

061-82108050

Exibições: 931

Anexos

Responder agora

Respostas a este tópico

Estou com o mesmo problema, se possível alguém poderia ajudar , agradeço.

Pedro Ajuda nós

O Meu boleto do sicredi não gera o nosso número ele funciona quando quer :/

Aqui estou com mesmo problema só que com boleto do Bradesco, o mkauth até  ler o arquivo de retorno e identifica o titulo, mas por algum motivo ele não encontra o titulo no sistema, embora o nosso numero do arquivo de retorno esteja idêntico ao do mkauth, igual ao da sua imagem. Nos ajude Pedrão... 

SR. PEDRO  , peço que verifique sobre este problema. fiz novo testes e nao funciona mesmo, o MK AUTH nao emcontra o boleto. aguardo .

Não sei se vai ajudar vc, no meu caso pq eu não estava  colocando todas as contas, como tenho contas diferentes achava  uns outro não, segue exemplo foto

Anexos

Realmente, era só esse detalhe, obrigado pela ajuda meu amigo, era só desatenção.

Galvao disse:

Não sei se vai ajudar vc, no meu caso pq eu não estava  colocando todas as contas, como tenho contas diferentes achava  uns outro não, segue exemplo foto

Sem palavras, era isto mesmo, valeu , abraço.

tenho muitas outras duvidas, se puder dar a dica agradeço,meu skype, (top...net),

Obrigado Era Isto mesmo Vacilo Meu, VLW

Galvao disse:

Não sei se vai ajudar vc, no meu caso pq eu não estava  colocando todas as contas, como tenho contas diferentes achava  uns outro não, segue exemplo foto

estou com problema eu uso boletos sem registro que o nosso numero começa com 24.........., ate ai blz , os boletos geram normalmente porem quando eu gero o arquivo de remeça para mandar para o banco os números mudam em vez de começarem com o numero 24. eles mudam para 14........ ai  que  faço.???

Responder à discussão

RSS

TheLinuxF

© 2018   Criado por Pedro Filho.   Ativado por

Badges - Divulgar  |  Relatar erro no site  |  Termos de serviço