INSTALAR MAIS UM PHP NO MK-AUTH

Bom dia,  

Estou tentando há dias instalar um versão mais nova do php dentro do mk-auth, porém ele não permite que seja instalado qualquer outra versão. Queria saber se isso é possivel e como é realizado esse processo de instalção já que os comandos basicos de instalação não funciona no putty. 

Se o pedro tiver alguma ideia me passa ai. Precisando rodar uma aplicação que roda em php 7 e não consigo porque o mk-auth encapsilou a versão 5.3 e pelo visto fechou para rodar o comando de instalação do php. A minha ideia era instalar o php 7 ou 8 mesmo, e usar virtual host para consultar cada php individual, porém não consigo nem instalar nenhuma versão pelo putty.

Obrigado

erro.jpg

Para adicionar comentários, você deve ser membro de MK-AUTH.

Join MK-AUTH

Enviar-me um email quando as pessoas responderem –

Respostas

  • não da pra instalar dois servidor apache, vc teria que usar outro servidor dentro do mk-auth

  • No debian e outro Linux é possível não instalar outro apache, mas é possível criar rotas através dos módulos do apache que possibilitam atraves de portas esse acesso a duas versões do php. O problema é que eu não estou conseguindo instalar o php pelo putty em outra versão dentro do servidor mk-auth. Isso em qualquer linux diferente do mk-auth é possivel. Queria apenas instalar o php e fazer um virtual host nele.

    Ramon Igo Da Silva disse:

    não da pra instalar dois servidor apache, vc teria que usar outro servidor dentro do mk-auth

  • acho que não da pra usar o php7, pq o codigo do mk-auth e antigo, recomendo e vc instalar outro servidor separado mesmo ou usar o servidor diferente em outra porta.

    Cicomp disse:

    No debian e outro Linux é possível não instalar outro apache, mas é possível criar rotas através dos módulos do apache que possibilitam atraves de portas esse acesso a duas versões do php. O problema é que eu não estou conseguindo instalar o php pelo putty em outra versão dentro do servidor mk-auth. Isso em qualquer linux diferente do mk-auth é possivel. Queria apenas instalar o php e fazer um virtual host nele.

    Ramon Igo Da Silva disse:

    não da pra instalar dois servidor apache, vc teria que usar outro servidor dentro do mk-auth

  • ser vc usar o php7 vai ter um monte de erro, vai na minha, eu ja fiz isso

  • Por segurança no sistema uso um PHP que eu mesmo compilei com algumas tecnologias que criei e somente com o que é preciso para o sistema funcionar, instalar outro PHP pelo APT desconfigura ele, só que vc pode usar o docker, com ele é muito fácil configurar outras versões do PHP no sistema, no google tem muito material de como instalar e configurar o docker no debian...

  • obrigado Pedro e ao Ramon. vou verificar essa possibilidade.

    Pedro Filho disse:

    Por segurança no sistema uso um PHP que eu mesmo compilei com algumas tecnologias que criei e somente com o que é preciso para o sistema funcionar, instalar outro PHP pelo APT desconfigura ele, só que vc pode usar o docker, com ele é muito fácil configurar outras versões do PHP no sistema, no google tem muito material de como instalar e configurar o docker no debian...

This reply was deleted.