MK-AUTH

Como dizem. “De graça aprendi, de graça repasso”.

Para quem também tem problemas como eu com os bit-torrent´s, que passa por cima de tudo que é controle de banda, não temos alternativas a não ser bloquear. Desta forma, estudei quais melhores regras se adaptariam e após varias tentativas, cheguei a seguintes:

 

1 – Vamos criar as regras no ip firewall layer7:

/ip firewall layer7-protocol
add name=teamspeak regexp="^\F4\BE\03.*teamspeak"
add name=worldofwarcraft regexp="^\06\EC\01"
add name=ventrilo regexp="^..\?v\\\$\CF"
add name=edonkey regexp="^[\C5\D4\E3-\E5].\?.\?.\?.\?([\01\02\05\14\15\16\18\19\1A\1B\1C !234568@ABCFGHIJKLMNOPQRSTUVWX[`\81\82\90\91\93\96\97\98\99\9A\9B\9C\9E\A0\A1\A2\A3\
    \A4]|Y................\?[ -~]|\96....\$)"
add name=goboogy regexp="<peerplat>|^get /getfilebyhash\\.cgi\\\?|^get /queue_register\\.cgi\\\?|^get /getupdowninfo\\.cgi\\\?"
add name=soribada regexp="^GETMP3\r\
    \nFilename|^\01.\?.\?.\?(Q:\\+|Q2:)|^\10[\14-\16]\10[\15-\17].\?.\?.\?.\?\$"
add name=rdp regexp=rdpdr.*cliprdr.*rdpsnd
add name=gnutella regexp="^(gnd[\01\02]\?.\?.\?\01|gnutella connect/[012]\\.[0-9]\r\
    \n|get /uri-res/n2r\\\?urn:sha1:|get /.*user-agent: (gtk-gnutella|bearshare|mactella|gnucleus|gnotella|limewire|imesh)|get /.*content-type: application/x-gnutella-packe\
    ts|giv [0-9]*:[0-9a-f]*/|queue [0-9a-f]* [1-9][0-9]\?[0-9]\?\\.[1-9][0-9]\?[0-9]\?\\.[1-9][0-9]\?[0-9]\?\\.[1-9][0-9]\?[0-9]\?:[1-9][0-9]\?[0-9]\?[0-9]\?|gnutella.*cont\
    ent-type: application/x-gnutella|...................\?lime)"
add name=bittorrent regexp="^(\13bittorrent protocol|azver\01\$|get/scrape\\\?info_hash=)|d1:ad2:id20:|\08'7P\\)[RP]"
add name=ares regexp="^\03[]Z].\?.\?\05\$"
add name=fasttrack regexp="^get (/.download/[ -~]*|/.supernode[ -~]|/.status[ -~]|/.network[ -~]*|/.files|/.hash=[0-9a-f]*/[ -~]*) http/1.1|user-agent: kazaa|x-kazaa(-usern\
    ame|-network|-ip|-supernodeip|-xferid|-xferuid|tag)|^give [0-9][0-9][0-9][0-9][0-9][0-9][0-9][0-9]\?[0-9]\?[0-9]\?"
add name=100bao regexp="^\01\01\05\
    \n"
add name=torrent-wwws regexp="^.*(get|GET).+(torrent|thepiratebay|isohunt|entertane|demonoid|btjunkie|mininova|flixflux|vertor|h33t|zoozle|bitnova|bitsoup|meganova|fulldls|\
    btbot|fenopy|gpirate|commonbits).*\$"
add name=torrent-dns regexp="^.+(torrent|thepiratebay|isohunt|entertane|demonoid|btjunkie|mininova|flixflux|vertor|h33t|zoozle|bitnova|bitsoup|meganova|fulldls|btbot|fenopy\
    |gpirate|commonbits).*\$"

2 – Agora vamos crias os pontos no ip firewall filter:

/ip firewall filter
add action=drop chain=forward comment=p2p disabled=no layer7-protocol=ares
add action=drop chain=forward disabled=no layer7-protocol=bittorrent
add action=drop chain=forward disabled=no layer7-protocol=edonkey
add action=drop chain=forward disabled=no layer7-protocol=counterstrike-source
add action=drop chain=forward disabled=no layer7-protocol=100bao
add action=drop chain=forward comment="block torrent wwws" disabled=no layer7-protocol=torrent-wwws
add action=drop chain=forward comment="block torrent dns" disabled=no dst-port=53 layer7-protocol=torrent-dns protocol=udp

Exibições: 3203

Responder agora

Respostas a este tópico

vlw a dica...

serve pra utorrent ?

tire uma duvida se o cliente já tem um limite de banda definido por exemplo de 2MB ele não so conseguria usar o bit ou utorrent a 256 kbps? desculpe mas sou meio leigo ainda.. aprendendo .

essas regras bloqueiam sites como mkauth e deixam a net lenta. assim que apliquei elas aqui aconteceu isso ficou lento e alguns sites nao abrem excluir voltou tudo ao normal

valeu o aviso...

SEU MADRUGA disse:

essas regras bloqueiam sites como mkauth e deixam a net lenta. assim que apliquei elas aqui aconteceu isso ficou lento e alguns sites nao abrem excluir voltou tudo ao normal

Responder à discussão

RSS

Links

© 2021   Criado por Pedro Filho.   Ativado por

Badges - Divulgar  |  Relatar erro no site  |  Termos de serviço