MK-AUTH

Olá pessoal

Venho hoje compartilhar uma experiência sobre backup automático do mk-auth para mikrotik.

São apenas 2 passos e o minimo de código:

1 Passo - MK-AUTH 

Acessar o menu Backup e habilitar o envio de backup por FTP e coloca o IP, usuario e senha com acesso ao seu mikrotik. Isso faz com que o mk-auth envie três arquivos para o mikrotik pra dentro de files (mikrotik.rsc, dhcp.rsc e pgaviso.rsc)

2 Passo - MIKROTIK

Verificar se a porta 21 do FTP esta habilitada em IP Service depois é so adicionar o código abaixo em Tools Netwatch na aba down que checa o status do mkauth.

PARA QUEM USA PPPoE:

:if ( [/file find name=mikrotik.rsc] != "" ) do={
:log warning "Processando backup do MkAuth. Aguarde!";
/ppp profile remove [/ppp profile find where comment=mkauth]
/ppp secret remove [/ppp secret find where comment=mkauth]
/ip hotspot user profile remove [/ip hotspot user profile find name!=default]
/ip hotspot user remove [/ip hotspot user find comment=mkauth]
/import file-name=mikrotik.rsc;
/import file-name=dhcp.rsc;
/import file-name=pgaviso.rsc;
:log warning "Backup Foi Importado Com Sucesso!";
} else={
:log error "Backup Nao Foi Importado!";
}

/ppp secret set [find comment=mkauth] disabled=no

Obs.: Eu adicionei essas duas linha do hotspot que estão em negrito para evitar erro porque o Mkauth esta enviando os profiles do hotspot junto, mesmo sem voce ter cliente cadastrado como hotspot. Acho que é uma falha e logo será corrigido.

Para quem não gosta de ter trabalho segue o arquivo para colar no New Terminal.

Exibições: 927

Anexos

Responder agora

Respostas a este tópico

o meu dar essa mensagem 

invalid value for argument local-address:\r\n input does not match any
value of pool\r\n invalid value for argument address

o meu mesma coisa



PORTAL ANI disse:

Alguém tem atualização desse script? aqui não funcionou fez foi remover os usuário e não habilita automático

Esse script continua funcionando normalmente.

Acredito que seja os nomes dos profiles.



PORTAL ANI disse:

Alguém tem atualização desse script? aqui não funcionou fez foi remover os usuário e não habilita automático

aqui exportou tudo certo porem ja tinha alguns usuário la ele removeu tudo que era mkaut e não ativou ao radiu esta offline removeu tudo ate profile automatico

Antonio Brito disse:

Esse script continua funcionando normalmente.

Acredito que seja os nomes dos profiles.



PORTAL ANI disse:

Alguém tem atualização desse script? aqui não funcionou fez foi remover os usuário e não habilita automático

Nos profiles dos planos o meu vem com dns do google, porem uso proprio, onde altero os dns?

Encontrei, se alguem precisar fica em: /opt/mk-auth/mkt/mkt.inc

Speednet WiFi - Christiano disse:

Nos profiles dos planos o meu vem com dns do google, porem uso proprio, onde altero os dns?

O meu passou a da erro tambem. 

Verifiquei que o Mk-auth tava trazendo uma linha dentro do arquivo com esse conteudo:

/interface wireless access-list add interface=all forwarding=no authentication=yes signal-range=-120..120......

Daí é só marcar todos os clientes e alterar em massa, mudando a opção para não como segue:

Rede sem fio
Access-List:
Criptografia:
Bom dia Galera.. por favor.. meu mk-auth 4.99 ele cria um arquivo .tgz no lugar desses 3 arquivos.. como faço ?

Responder à discussão

RSS

parcerias

© 2020   Criado por Pedro Filho.   Ativado por

Badges - Divulgar  |  Relatar erro no site  |  Termos de serviço