MK-AUTH

Olá pessoal

Venho hoje compartilhar uma experiência sobre backup automático do mk-auth para mikrotik.

São apenas 2 passos e o minimo de código:

1 Passo - MK-AUTH 

Acessar o menu Backup e habilitar o envio de backup por FTP e coloca o IP, usuario e senha com acesso ao seu mikrotik. Isso faz com que o mk-auth envie três arquivos para o mikrotik pra dentro de files (mikrotik.rsc, dhcp.rsc e pgaviso.rsc)

2 Passo - MIKROTIK

Verificar se a porta 21 do FTP esta habilitada em IP Service depois é so adicionar o código abaixo em Tools Netwatch na aba down que checa o status do mkauth.

PARA QUEM USA PPPoE:

:if ( [/file find name=mikrotik.rsc] != "" ) do={
:log warning "Processando backup do MkAuth. Aguarde!";
/ppp profile remove [/ppp profile find where comment=mkauth]
/ppp secret remove [/ppp secret find where comment=mkauth]
/ip hotspot user profile remove [/ip hotspot user profile find name!=default]
/ip hotspot user remove [/ip hotspot user find comment=mkauth]
/import file-name=mikrotik.rsc;
/import file-name=dhcp.rsc;
/import file-name=pgaviso.rsc;
:log warning "Backup Foi Importado Com Sucesso!";
} else={
:log error "Backup Nao Foi Importado!";
}

/ppp secret set [find comment=mkauth] disabled=no

Obs.: Eu adicionei essas duas linha do hotspot que estão em negrito para evitar erro porque o Mkauth esta enviando os profiles do hotspot junto, mesmo sem voce ter cliente cadastrado como hotspot. Acho que é uma falha e logo será corrigido.

Para quem não gosta de ter trabalho segue o arquivo para colar no New Terminal.

Exibições: 1053

Anexos

Responder agora

Respostas a este tópico

irei resolver essa falha...

alterado, faz um update e testa ai Brito.

Boa noite meu amigo, achei interessante esse seu script e to testando ele aqui. Dai me surgiu uma duvida... em qual periodo de tempo o mikrotik vai pegar os secrets do mk-ath e importar?

Olá Ronei Alcantara, eu não sei te responder com exatidão mas acho que é a cada 10 ou 15 minutos. 

Tem alguma forma de eu saber se esta funcionando certinho o script?

Antonio Brito disse:

Olá Ronei Alcantara, eu não sei te responder com exatidão mas acho que é a cada 10 ou 15 minutos. 

Caso o radius fique off é habilitado a autenticação no mikrotik ?

Exatamente Fastway

Da pra ver a rotina sendo executada aba Secrets do PPPoE.



FastWay Telecom disse:

Caso o radius fique off é habilitado a autenticação no mikrotik ?

Sim.

Basta acessar a pasta Files da RB e ver se o MK-AUTH enviou os arquivos para lá:

mikrotik.rsc

pgaviso.rsc

dhcp.rsc

Se estiverem lá vai até a aba Secrets do PPPoE observe o que acontece quando você desconecta o mk-auth.

Ronei Alcantara Botelho disse:

Tem alguma forma de eu saber se esta funcionando certinho o script?

Antonio Brito disse:

Olá Ronei Alcantara, eu não sei te responder com exatidão mas acho que é a cada 10 ou 15 minutos. 

ola pessoal o meu aqui quando eu rodo o script ele so vai uma parte dos clientes e no log eu vejo que da um erro  (script error:input does not match any value of profile) 

Os nomes dos Planos nao pode ter espaco:
Ex: PlanoBasico ou Plano_Basico ou simplesmente Basico
eu vi os nomes estão tudo ok sera que não pode ser o tamanho do arquivo não ?

Alguém tem atualização desse script? aqui não funcionou fez foi remover os usuário e não habilita automático

Responder à discussão

RSS

parcerias

© 2020   Criado por Pedro Filho.   Ativado por

Badges - Divulgar  |  Relatar erro no site  |  Termos de serviço