MK-AUTH

Boa noite pessoal? Instalei tem uns dias 1 mk-auth para testes e quero coloca-lo em produção quando tiver todos os módulos funcionando perfeitamente! No momento a parte de log e financeiro esta funcionando perfeitamente, só que estou enfrentando problemas para que o bloqueio funcione e para que as paginas de aviso funcionem tanto para hotspot quanto para ppoe (no momento nenhuma esta funcionando e nem o bloqueio)! Queria também saber como que funciona os avisos via email pois o único que recebi foi o de backup, chamado respondido e a de boleto só vai se eu clicar em enviar! Gostaria também saber se e possível que este aviso via email tenha o link com o boleto atualizado ou acesso a central?

Segue em anexo o print da tela de cadastro de servidores e também do firewall do MK!

Obrigado a quem puder ajudar!

OBS: to usando corte via ssh e se eu colocar para bloquear manualmente ele vai pra access-lis e bloqueia, mas eu quero que funcione automaticamente!

Exibições: 216

Anexos

As respostas para este tópico estão encerradas.

Respostas a este tópico

se vc usa a pagina de corte por radius, uma forma de vc saber se seu cliente realmente esta bloqueado no radius e clica no link informações que tem abaixo do nome do cliente e na janela que abre na parte de radius veja se tem os parametros Mikrotik-Mark-Id / Framed-Pool (clientes hotspot) ou Mikrotik-Address-List / Framed-Pool (clientes pppoe) como na imagem abaixo, se tem então o erro com certeza é no MikroTik por isso depois do login, veja se o cliente bloqueado aparece no mangle do MikroTik (hotspot) ou veja se o ip do cliente bloqueado entra no address-list do MikroTik (pppoe):

se vc usa a pagina de corte por ssh, uma forma de vc saber se seu cliente realmente esta bloqueado é ver se na address-list o ip do cliente aparece, se não aparece veja se não é falha na comunicação ssh, clique no link informações da pagina de ramais MikroTik e veja se aparece os dados como na imagem abaixo, caso os dados sejam mostrados com sucesso então a razão do bloqueio por ssh não funcionar é pq o cliente não tem um ip definido no cadastro dele ou nunca tenha se conectado ao provedor.

nas duas formas de bloqueio é preciso colocar a regra de redirecionamento para pagina de corte acima da regra de nat para o proxy no nat do MikroTik e nas configurações de profile de hotspot do MikroTik é preciso deixar a opção transparet proxy desativada.

veja abaixo as regras atuais para exibir a pagina de corte com radius ou ssh:

Para todos os clientes:

/ip firewall nat

add action=dst-nat dst-address=!172.31.255.2 chain=dstnat comment="PG CORTE" disabled=no hotspot=from-client,auth protocol=tcp src-address-list=pgcorte to-addresses=172.31.255.2 to-ports=85

Para hotspot com radius (pool):

/ip pool

add name=pgcorte ranges=10.3.0.2-10.3.3.254

/ip address

add address=10.3.0.1/22 broadcast=10.3.3.255 network=10.3.0.0 interface=Placa do clientes

/ip firewall nat

add action=dst-nat dst-address=!172.31.255.2 chain=dstnat comment="PG CORTE" disabled=no protocol=tcp src-address=10.3.0.2-10.3.3.254 to-addresses=172.31.255.2 to-ports=85

Para hotspot com radius (mangle):

/ip firewall mangle

add chain=prerouting action=jump comment="PG CORTE" jump-target=hotspot

/ip firewall nat

add chain=hotspot comment="PG CORTE" packet-mark=bloqueado protocol=tcp action=dst-nat to-addresses=172.31.255.2 to-ports=85



Harlen Silveira Pinho disse:

Favor alguém pode ajudar?

Pedro conseguir funcionar a tela de bloqueio com ssh só que só bloqueia e desbloqueia se fizer manualmente no sistema, automaticamente não esta funcionando! Alguém sabe como resolver? Qual seria melhor opção para funcionar o bloqueio e as mensagens?

Pedro Filho disse:

se vc usa a pagina de corte por radius, uma forma de vc saber se seu cliente realmente esta bloqueado no radius e clica no link informações que tem abaixo do nome do cliente e na janela que abre na parte de radius veja se tem os parametros Mikrotik-Mark-Id / Framed-Pool (clientes hotspot) ou Mikrotik-Address-List / Framed-Pool (clientes pppoe) como na imagem abaixo, se tem então o erro com certeza é no MikroTik por isso depois do login, veja se o cliente bloqueado aparece no mangle do MikroTik (hotspot) ou veja se o ip do cliente bloqueado entra no address-list do MikroTik (pppoe):

se vc usa a pagina de corte por ssh, uma forma de vc saber se seu cliente realmente esta bloqueado é ver se na address-list o ip do cliente aparece, se não aparece veja se não é falha na comunicação ssh, clique no link informações da pagina de ramais MikroTik e veja se aparece os dados como na imagem abaixo, caso os dados sejam mostrados com sucesso então a razão do bloqueio por ssh não funcionar é pq o cliente não tem um ip definido no cadastro dele ou nunca tenha se conectado ao provedor.

nas duas formas de bloqueio é preciso colocar a regra de redirecionamento para pagina de corte acima da regra de nat para o proxy no nat do MikroTik e nas configurações de profile de hotspot do MikroTik é preciso deixar a opção transparet proxy desativada.

veja abaixo as regras atuais para exibir a pagina de corte com radius ou ssh:

Para todos os clientes:

/ip firewall nat

add action=dst-nat dst-address=!172.31.255.2 chain=dstnat comment="PG CORTE" disabled=no hotspot=from-client,auth protocol=tcp src-address-list=pgcorte to-addresses=172.31.255.2 to-ports=85

Para hotspot com radius (pool):

/ip pool

add name=pgcorte ranges=10.3.0.2-10.3.3.254

/ip address

add address=10.3.0.1/22 broadcast=10.3.3.255 network=10.3.0.0 interface=Placa do clientes

/ip firewall nat

add action=dst-nat dst-address=!172.31.255.2 chain=dstnat comment="PG CORTE" disabled=no protocol=tcp src-address=10.3.0.2-10.3.3.254 to-addresses=172.31.255.2 to-ports=85

Para hotspot com radius (mangle):

/ip firewall mangle

add chain=prerouting action=jump comment="PG CORTE" jump-target=hotspot

/ip firewall nat

add chain=hotspot comment="PG CORTE" packet-mark=bloqueado protocol=tcp action=dst-nat to-addresses=172.31.255.2 to-ports=85



Harlen Silveira Pinho disse:

Favor alguém pode ajudar?

mais prints!

Anexos

add Harlen.

Skype, speedynetwork

isso ai pode ser: opções / gerenciar recursos/

desbloqueio de venciados marcados com sim

e outra coisa, serviços não bloqueia.

Realmente amigo foi só mudar de serviços para mensalidade que o sistema bloqueou!

Obrigado pela ajuda!

Pedro Alves de Almeida Junior disse:

isso ai pode ser: opções / gerenciar recursos/

desbloqueio de venciados marcados com sim

e outra coisa, serviços não bloqueia.

RSS

TheLinuxF

© 2018   Criado por Pedro Filho.   Ativado por

Badges - Divulgar  |  Relatar erro no site  |  Termos de serviço