MK-AUTH

Pessoal, está acontecendo um problema estranho na minha rede. Nas ultimas semanas, alguns equipamentos UBNT (nanostations Loco e Nanobridges M5), estão se desconectando das torres e depois não voltam a se conectar sozinhos a menos que sejam reiniciados (tirando e colocando na tomada). O tempo em que isso ocorre é variável, as vezes ficam dois a três dias conectados e as vezes caem duas ou três vezes por dia...
Uma coincidência entre os equipamentos que apresentaram o defeito, é que quando reiniciados, apesar de funcionarem perfeitamente por um tempo, perdi o acesso completamente através da pagina web, mas consigo acessar o equipamento por SSH.

As perguntas que faço são: 01 - qual a linha de comando e procedimentos para se fazer upload de um backup de um equipamento "saudável" para os defeituosos por SSH?

 

02 - Alguém mais tem passado por este problema?

 

Desde já, muito obrigado pelas respostas.

Exibições: 1995

Responder agora

Respostas a este tópico

Aqui começou a ocorrer isto amigo a umas duas semana em um NanoLoco fica uns 10 dias on e depois tenho que desligar e ligar da tomada. mais nao perdo o acesso dele pela web.

Pois é... To querendo subir um backup por SSH mas nao sei o procedimento e nao encontro em lugar nenhum...

 

Galera, ninguém sabe?

Amigo também perdir o acesso a um nanoloco, para resolver isso fis esse procedimento?

PROCEDIMENTO P/RECUPERAR FIRMWARE COM TFTP

 

Quem Precisa Fazer Este Procedimento

- Usuários que perderam acesso a seus rádios e também desabilitaram o botão físico de RESET.

- Usuários que precisam carregar o firmware original no equipamento.

 

Preparação Para o Procedimento

- Obtenha o firmware do seu equipamento no site da Ubiquiti (http://ubnt.com/support/downloads) e salve no PC que realizará o procedimento.

- Configure a interface cabeada do PC para usar o IP 192.168.1.222/255.255.255.0

- Conecte um cabo de rede entre o PC e o rádio Ubiquiti, não use hub ou switch.

- Quem usa Win7 vai precisar do TFTP2.

 

Preparando o Rádio para Receber o Firmware

1) Desligue o rádio da energia.

2) Pressione e segure o botão RESET com um clips de papel e ligue o rádio na energia.

3) Mantenha o botão de RESET pressionado por 20 segundos ou até os LEDS acenderem.

4) Quando os LEDS acenderem o rádio está pronto para receber o firmware através do FTP.

5) Ping o IP 192.168.1.20 para ter certeza que o rádio está respondendo. Se não responder ao PING repita esta etapa.

 

Carregando o Firmware no Rádio

1) Abra o prompt de comando do windows.

2) Vá até a pasta onde você salvou o arquivo do firmware.

3) digite o seguinte comando e pressione ENTER:

fttp -i 192.168.1.20 put NOME_EXATO_DO_ARQUIVO.bin

ou

ftp -s:NOME_EXATO_DO_ARQUIVO.bin 192.168.1.20

4) Aguarde o sistema operacional informar o término do carregamento do arquivo.

5) O procedimento de carregamento do firmware pode levar até 10 minutos.

6) Seja Paciente, NUNCA DESLIGUE O RÁDIO antes do término do carregamento, porque pode inutilizar seu equipamento.

 

O Win7 não aceita os comandos acima.

Neste caso tem que rodar e configurar o TFP2 pra subir o arquivo.

Feito pelo Ze Alves

Link:GRANLARBO

Para resolver o problema dos nanos trava e perde acesso, fis isso!!

Amigo, muito obrigado pela resposta, mas eu não tenho como resetar a nanobridge. Acontece que ela está sobre um prédio de 03 andares, e o único jeito de subir no telhado era colocando a escada em uma sacada no andar de baixo, porem, fizeram uma cobertura de acrílico sobre essa sacada e já era. Ou eu perco o cliente ou conserto esse negócio...
Precisava de um meio para colocar o backup realmente por SSH que é o único meio para ter algum acesso ao equipamento.
obrigado.
 
Carlos disse:

Amigo também perdir o acesso a um nanoloco, para resolver isso fis esse procedimento?

PROCEDIMENTO P/RECUPERAR FIRMWARE COM TFTP

 

Quem Precisa Fazer Este Procedimento

- Usuários que perderam acesso a seus rádios e também desabilitaram o botão físico de RESET.

- Usuários que precisam carregar o firmware original no equipamento.

 

Preparação Para o Procedimento

- Obtenha o firmware do seu equipamento no site da Ubiquiti (http://ubnt.com/support/downloads) e salve no PC que realizará o procedimento.

- Configure a interface cabeada do PC para usar o IP 192.168.1.222/255.255.255.0

- Conecte um cabo de rede entre o PC e o rádio Ubiquiti, não use hub ou switch.

- Quem usa Win7 vai precisar do TFTP2.

 

Preparando o Rádio para Receber o Firmware

1) Desligue o rádio da energia.

2) Pressione e segure o botão RESET com um clips de papel e ligue o rádio na energia.

3) Mantenha o botão de RESET pressionado por 20 segundos ou até os LEDS acenderem.

4) Quando os LEDS acenderem o rádio está pronto para receber o firmware através do FTP.

5) Ping o IP 192.168.1.20 para ter certeza que o rádio está respondendo. Se não responder ao PING repita esta etapa.

 

Carregando o Firmware no Rádio

1) Abra o prompt de comando do windows.

2) Vá até a pasta onde você salvou o arquivo do firmware.

3) digite o seguinte comando e pressione ENTER:

fttp -i 192.168.1.20 put NOME_EXATO_DO_ARQUIVO.bin

ou

ftp -s:NOME_EXATO_DO_ARQUIVO.bin 192.168.1.20

4) Aguarde o sistema operacional informar o término do carregamento do arquivo.

5) O procedimento de carregamento do firmware pode levar até 10 minutos.

6) Seja Paciente, NUNCA DESLIGUE O RÁDIO antes do término do carregamento, porque pode inutilizar seu equipamento.

 

O Win7 não aceita os comandos acima.

Neste caso tem que rodar e configurar o TFP2 pra subir o arquivo.

Feito pelo Ze Alves

Link:GRANLARBO

Para resolver o problema dos nanos trava e perde acesso, fis isso!!

Não ira ajudar no problema de nosso amigo, mas funciona sim no Windows 7/8, apenas tem que habilitar o Cliente TFTP na aba "Programas e Recursos" opção "Ativar ou Desativar recursos do Windows"

Já tentou resetar ele por SSH e ver se o acesso web no 192.168.1.20 não retorna?

Comando: 

# cfgmtd -f /usr/etc/system.cfg -w && reboot

Riberto, boa noite.

Esse problema que vc esta relatando, parece muito com o caso do Worm SkyNet.

Qual a versão do fw instalada no equipamento?

Para remover o Worm por SSH (Não perde a configuração):

rm /etc/persistent/rc.poststart
rm -rf /etc/persistent/.skynet
cfgmtd -w -p /etc/
reboot

Seria interessante vc colocar essa regra no seu mikrotik que evita de propagar o vírus.

/ip firewall filter
add action=add-src-to-address-list address-list=virus_ubnt address-list-timeout=1w3d chain=forward comment="LISTAR INFECTADOS SKYNET" disabled=no dst-address=178.216.144.75
add action=drop chain=forward comment="BLOQUEIO INFECTADOS SKYNET" disabled=no dst-address=178.216.144.75 src-address-list=virus_ubnt

Att;

JM

João, os problemas começaram depois que atualizei em massa para V5.5.3. Interessante que mesmo eu fazendo o upgrade para V5.5.4 ou downgrade para V5.3.5 através do aircontrol, eles mudam o firmware e o problema continua.

Estou com o mesmo problema em 04 clientes, e acabei de descer um dos nanos e fazer a reinstalação por TFTP e o equipamento voltou a vida com firm V5.5.4, porém notei que o equipamento não apresentou no firmware aquele selo de "genuine product" no canto inferior direito, portanto, corro risco de ter comprado gato por lebre e estar com alguns produtos falsificados em mãos.
Frente a essa possibilidade, somente comprei TODOS OS MEUS EQUIPAMENTOS, em dois forncedores, sendo um deles a Flytec/Excell do Paraguai, e um conhecido fornecedor nacional que por hora prefiro não dizer o nome para não levantar falsas suspeitas, mas sabemos que a unica distribuidora UBNT em toda a América do Sul é a Flytec, portanto, indiferente de quem compramos no Brasil, eles vieram todos do mesmo lugar no PY, e se houve de fato a tal falsificação, duas sacanagens gigantes estão acontecendo. 01 - os produtos falsificados vieram de dentro da distribuidora oficial da empresa, e 02 - mesmo com essa enorme falha na distribuição oficial (se foi isso realmente), lançaram um firmware (V5.5.3) que danifica o software e trava intencionalmente produtos não originais.
Se fosse um produto comprado em qualquer camelô, tudo bem, me calava para uma atualização que por ventura viesse a acontecer, mas foi um produto comprado em um distribuidor oficial, por preço de equipamento oficial em embalagens lacradas supostamente originais...
Eu sou da turma que passou um monte de raiva com as primeiras airgrids e equipamentos UBNT (perdi 92 airgrids) uns anos atrás por pura lambança dessa empresa que pelo jeito não tem o menor cuidado e controle dos seus produtos, e espero sinceramente que minhas suspeitas não se confirmem e eu não passe outra raiva com seus equipamentos.

Desde já, muito obrigado.


 
João Marcos Nabhen disse:

Riberto, boa noite.

Esse problema que vc esta relatando, parece muito com o caso do Worm SkyNet.

Qual a versão do fw instalada no equipamento?

Para remover o Worm por SSH (Não perde a configuração):

rm /etc/persistent/rc.poststart
rm -rf /etc/persistent/.skynet
cfgmtd -w -p /etc/
reboot

Seria interessante vc colocar essa regra no seu mikrotik que evita de propagar o vírus.

/ip firewall filter
add action=add-src-to-address-list address-list=virus_ubnt address-list-timeout=1w3d chain=forward comment="LISTAR INFECTADOS SKYNET" disabled=no dst-address=178.216.144.75
add action=drop chain=forward comment="BLOQUEIO INFECTADOS SKYNET" disabled=no dst-address=178.216.144.75 src-address-list=virus_ubnt

Att;

JM

Tem equipamento do ano anterior a 2012 que nao aparece a logo do genuine. somente de 2012 para cá.....

https://under-linux.org/showthread.php?t=163040

https://under-linux.org/showthread.php?t=154682

Caro Riberto, já tive esse problema e após muitas tentativas descobri que é problema de versão do firmware.... por exemplo, se eu tiver a versão 5.3 na repetidora e no cliente eu instalar um produto com versão 5.5, então ocorre o problema. No caso, eu atualizei todos os equipamentos para a mesma versão, o que resolveu o problema completamente. Também ouvi dizer que a repetidora teria que estar numa versão igual ou acima dos equipamentos pendurados nela... já fiz isso e também funcionou.

Atualizei tudo para V5.5.4 e o problema continua...
Acho que a solução será resetar tudo por TFTP mesmo, e perder o cliente que está em cima do prédio que não dá para alcançar...

Responder à discussão

RSS

Parceiros

 

© 2014   Criado por Pedro Filho.

Badges - Divulgar  |  Relatar erro no site  |  Termos de serviço