MK-AUTH

Regras para PAGINA de AVISO de MANUTENÇÃO AUTOMATICA EM HOTSPOT.

Depois de bater muita a cabeção aqui no Fórum conseguir juntar varias dicas e fiz minha pagina de manutenção automática funcionar, vai ai galera que não entende muito como eu, mas está funcionando direitinho:

 

IP Firewall Nat

Comment  (manutenção)

GENERAL

Add

Chain: dstnat

Src.Addres: 0.0.0.0/0

Protocol: tcp

Dst. Port: 80

ADVANCED

Src.Address List: Manutenção

ACTION

Action: dst-nat

To Addresses: (ip Mkauth)

To Ports: 89

------------------------------------------------------------------------------------------------------------------------------

IP Firewall Address Lists

 

Add

Comment (manutenção rede Local)  (manutenção Wifi) como queira

Name: manutenção

Address: (Faixa Ip dos seus clientes) Ex: 192.168.2.0/24 se tiver mas de uma faixa é só criar mas  regra seguindo a mesma sequencia.

------------------------------------------------------------------------------------------------------------------------------

Tools Netwatch

Add

Host

Comment (Status da Net)

Host: 200.154.56.80

Interval: 00:00:40

Timeout: 2000

 

Up

On Up: /ip firewall nat set [find comment="manutenção"] disabled=yes

Down

On Down: /ip firewall nat set [find comment="manutenção"] disabled=no

------------------------------------------------------------------------------------------------------------------------------

System Scripts

Add

Name: link-down

Policy  (marca= reboot, write, test, sniff, read, policy, password.)

Source: ip firewall nat set [find comment=manutenção] disabled=no

 

Add

Name: link-up

Policy  (marca= reboot, write, test, sniff, read, policy, password.)

Source: ip firewall nat set [find comment=manutenção] disabled=yes

 

Run Script

------------------------------------------------------------------------------------------------------------------------------

IP Hotspot Walled Garden

 

Add

 

Action: Allow

Dst. Host: (ip do Mkauth)

Dst. Port: 80-90

------------------------------------------------------------------------------------------------------------------------------

Pronto esta feita a sua pagina de AVISO de MANUTENÇÃO automática (toda vez que o link cair vai entra a pagina de MANUTENÇÃO).


Tags: ajuda, aviso, manuntenção, pagina, sistema

Exibições: 7144

Responder agora

Respostas a este tópico

obrigado pela dica.
Funcionaria se meu mk-auth estivesse fora da rede, no caso em outro lacal com ip real-fixo?
Blz, sofri muito com queda de link, e nao tinha nada pra avisar, mais agora gracas a Deus to com redundancia de link adquiri links de operadoras diferentes juntei num pcc, nunca mais tive problema de queda de link, mais pra quem ta so com um link muito boa essa dica valew....
seria uma boa dica para próxima atualização
cara essa regra serve para ppoe no meu caso aqui uso ppoe

Pra quem Gosta de coipiar e colar  ta aki e so copiar e coloar mais lei a legenda antes ok...

 

ip = 172.31.255.2 (Mk-auth)

ip = 10.0.0.0/8 (rede dos Clientes

 

/ip firewall nat

add action=dst-nat chain=dstnat comment="Manuten\E7\E3o" disabled=yes dst-port=80 protocol=tcp src-address=0.0.0.0/0 to-addresses=172.31.255.2  to-ports=89

/ip firewall address-list

add address=10.0.0.0/8 comment="" disabled=no list="MANUTEN\C7\C3O"

/tool netwatch

add comment="" disabled=no down-script="/ip firewall nat set [find comment=\"Manuten\E7\E3o\"] disabled=no\r\

    \n" host=8.8.8.8 interval=1m timeout=2s up-script="/ip firewall nat set [find comment=\"Manuten\E7\E3o\"] disabled=yes"

/ip hotspot walled-garden ip

add action=accept comment="Mk-auth" disabled=no dst-address=172.31.255.0/24 dst-port=80-90

 

creditos para o nosso amigo..

Adrian Carneiro

Caro amigo isso só pode funcionar sem net se o cliente estiver conectado.

Porque os navegadores procura primeiro um site externo e depois então o cliente e direcionado para o hotspot-

para se logar.

caso não aja resposta exibe pagina nao pode ser exibida.

caso vc coloque em dns fix ex www.google.com.br e sua pagina inicial seje está ai sim vai para pagina de login.

nao adianta bypsse no hotspot porque o nanegador vai ficar sem edereço da pa manutençao e nao vai encontrar nem um outro  a resposta é a mesma nao pode exibir a pa gina

 

sem net nao loga sem logar não a pagina de manutenção
Parabens Adrian pelo seu tutorial bem detalhado fico muito grato pois sou igual a vc gosto muito de desafios de aprender, parabens pela sua iniciativa será muito útil em meus testes.
Não consegui colocar pra funcionar vc pode me ajudar?

Anisio Machado regras criadas por min

regras para pagina de manutenção automatica
mesmo quando vc eata sem internete
mikrotik aparece a pg de login mesmo sem net

 

vamos la

 

clique em ip  aba dns clique em static

agora adicione

clique em + primeiro dns static  name www.google.com.br  dns 8.8.8.8

segundo dns www.uol.com.br    8.8.8.8

terceiro www.terra.com.br 8.8.8.8

quarto www.msn.com   8.8.8.8

 

 

agora regras do tools Netwatch host 8.8.8.8

up

 

/ip dns static disable 0

/ip dns static disable 1

/ip dns static disable 2

/ip dns static disable 3

 

Down

 

/ip dns static enable 0

/ip dns static enable 1

/ip dns static enable 2

/ip dns static enable 3

Ola, grande mestre  Anisio Machado !!!! qual versão está utilizando do mikrotik ??? pois criei essas regras tanto via Netwatch qto via Script mesmo e elas não entram em AÇÃO !!!! vejo que fica UP/DOWN mas não desabilita/habilita os DNS   em script também se mando RUN (executar) elas também não desabilita/habilita os DNS .

 

se vou no new terminal e colo elas ai sim desabilita/habilita os DNS.

 

Estou utilizando a versão 3.2

Responder à discussão

RSS

Parceiros

 

© 2014   Criado por Pedro Filho.

Badges - Divulgar  |  Relatar erro no site  |  Termos de serviço