MK-AUTH

Galera, recentemente percebi uma demora na abertura das páginas, e resolvi procurar o problema, simplesmente era o dns do google, mudei para o da gigadns e resolveu o problema.

A questão é, pq não colocar o mk-auth para ser também um server de cache, dae aumentei para 2gb de memoria o servidor, coloquei outra placa de rede, total de 2 no server e fiz os seguintes comandos:

apt-get update
após fiz o de instalação

apt-get install bind9


tudo maravilha, baixou um monte de arquivo e após pediu Y e fez as instalações.

então pergunto, qual seria a configuração ideal para rodar o mk-auth e bind serdo servidor de dns de minha rede?

alguém tem um tutorial para funcionar redondo, pois sou leigo nesse quesito, tenho medo de colocar p rodar e estragar o mk-auth.

Exibições: 2801

Responder agora

Respostas a este tópico

Amigo boa noite, você conseguiu fazer sua pagina de manutenção funcionar ao cair o link?

Marco de Freitas disse:

O cache DNS do Mikrotik pode ajudar. Só precisa bloqueá-lo para acesso externo.

O problema é que o firewall do Mikrotik trabalha com IP e o navegador precisa resolver (consultar qual IP) o site antes de continuar a conexão. O Hostpot resolve isso criando um DNS fake que sempre retorna o IP do Mikrotik para qualquer consulta DNS.

Ronei Alcantara Botelho disse:


Pedro como assim usa o DNS no próprio mikrotik? Pelo que percebi a PG MANUTENÇÃO somente funciona se tiver um servidor DNS no provedor correto ou estou enganado?

Tem muito tempo que isso não acontece.

A resolução DNS é condição básica. Sem DNS, apenas se o cliente tentar acessar um site por IP causará a redireção para a página de manutenção.

Faça um teste. Ative a manutenção para você, sem link. Tente acessar qualquer site por nome e depois por IP.

Ronei Alcantara Botelho disse:

Amigo boa noite, você conseguiu fazer sua pagina de manutenção funcionar ao cair o link?


No caso por ip aparece pg manutenção mais pelo endereço não. Como seria feito pra resolver isso haja visto que tds navegam pelo endereço. kkkk


Marco de Freitas disse:

Tem muito tempo que isso não acontece.

A resolução DNS é condição básica. Sem DNS, apenas se o cliente tentar acessar um site por IP causará a redireção para a página de manutenção.

Faça um teste. Ative a manutenção para você, sem link. Tente acessar qualquer site por nome e depois por IP.

Ronei Alcantara Botelho disse:

Amigo boa noite, você conseguiu fazer sua pagina de manutenção funcionar ao cair o link?

Precisa que o servidor DNS designado para a consulta esteja dentro da sua rede. Pode ser um Bind, Unbound ou até mesmo o cache DNS do Miktrotik. A resolução tem que acontecer ou a segunda fase, a conexão por IP, não acontece.

Ronei Alcantara Botelho disse:


No caso por ip aparece pg manutenção mais pelo endereço não. Como seria feito pra resolver isso haja visto que tds navegam pelo endereço. kkkk

Como faço esse cache DNS do Mikrotik pra funcionar amigo? Poderia me explicar.

Faça com o unbound. Muitos já utilizam assim a muitos anos. Rss e é super leve. Menos de 100gramas.

No Mikrotik:

/ip dns
set allow-remote-requests=yes servers=8.8.8.8



Ronei Alcantara Botelho disse:

Como faço esse cache DNS do Mikrotik pra funcionar amigo? Poderia me explicar.

Amigo aqui no meu mikrotik uso DNS da google mesmo, só que quando cai link não aparece página de manutenção para os clientes.

Aqui uso a regra abaixo, ela ativa e desativa blz a pg de manutenção quando link cai porem nao aparece a pagina no navegador, somente se colocar pra abrir por ip:

Segue regra:

/ip firewall nat
add action=dst-nat chain=dstnat comment="manuten\E7\E3o" disabled=yes dst-port=80 protocol=tcp src-address=10.2.0.1 to-addresses=172.31.255.2 to-ports=89

Depois criaremos em dns statics redirecionamentos dos principais sites que seus clients usam como página inicial para o ip 8.8.8.8. Para que quando seu link cair os clientes hotspot consigam logar e ver a pagina de manutenção. ;)

/ip dns static
add address=8.8.8.8 disabled=yes name=www.google.com.br ttl=1d
add address=8.8.8.8 disabled=yes name=www.terra.com.br ttl=1d
add address=8.8.8.8 disabled=yes name=www.uol.com.br ttl=1d
add address=8.8.8.8 disabled=yes name=www.msn.com ttl=1d
(pode criar com qualquer site)

Agora nós vamos criar uma regra netwatch, para monitorar o link e habilitar/desabilitar as regras acima conforme necessário.

/tool netwatch
add comment="Monitorar Link e dns statics" disabled=no down-script=\
"/ip dns static enable 0\r\
\n/ip dns static enable 1\r\
\n/ip dns static enable 2\r\
\n/ip dns static enable 3" host=8.8.8.8 interval=1m timeout=1s up-script=\
"/ip dns static disable 0\r\
\n/ip dns static disable 1\r\
\n/ip dns static disable 2\r\
\n/ip dns static disable 3"
add comment="Monitorar Link e regra manuten\E7\E3o" disabled=no down-script="/ip firewall nat set [find comment=\"manuten\E7\E3o\"] disabled=no" host=8.8.8.8 \
interval=1m timeout=2s up-script="/ip firewall nat set [find comment=\"manuten\E7\E3o\"] disabled=yes"
add comment="Monitorar cache" disabled=no down-script="/ip firewall mangle disable 0\r\

Pronto assim o mikrotik fica enviando pings ao ip 8.8.8.8 a cada 1min, enquanto estiver respondendo as regras de dns statics e de manutenção ficam desabilitadas, se parar de responder ele habilita automaticamente.


Paguei pra um cara fazer ele pra mim no proprio mk-auth mais ele nunca conseguiu por pra funcionar. Você consegue fazer ou tem contato de alguém que faça amigo?


Luis Eduardo Ramalho disse:

Faça com o unbound. Muitos já utilizam assim a muitos anos. Rss e é super leve. Menos de 100gramas.

PESSOAL BOM  DIA TEM ALGUM TUTORIA PARA INSTALA O EMBY NO MK-AUTH  POR FAVOR 

Pessoal, estou tentando instalar o Unbound DNS no meu MK-AUTH mas sempre que faço o comando "apt-get install unbound" ele me aparece essa mensagem de erro: 

root@mk-auth:~# apt-get install unbound
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Você deve querer executar 'apt-get -f install' para corrigí-los:
Os pacotes a seguir têm dependências desencontradas:
mariadb-server : Depende: mariadb-server-10.0 (>= 10.0.25-0+deb8u1) mas 10.0.20 +maria-1~jessie está para ser instalado
unbound : Depende: unbound-anchor mas não será instalado
E: Dependências desencontradas. Tente 'apt-get -f install' sem nenhum pacote (ou especifique uma solução).

Alguém sabe como resolver isso? e esse erro dá também quando tento instalar o Zabbix, quase tudo que eu tento instalar nesse Debian do mk-autk tá dando esse mesmo erro. E quando tento fazer esse comando pra reparar o banco de dados "apt-get install -f" ele dá esse erro: 

root@mk-auth:~# apt-get install -f
Lendo listas de pacotes... Pronto
Construindo árvore de dependências
Lendo informação de estado... Pronto
Corrigindo dependências... Pronto
Os pacotes extra a seguir serão instalados:
mariadb-server-10.0 mariadb-server-core-10.0
Pacotes sugeridos:
mariadb-test tinyca
Os pacotes a seguir serão atualizados:
mariadb-server-10.0 mariadb-server-core-10.0
2 pacotes atualizados, 0 pacotes novos instalados, 0 a serem removidos e 173 não atualizados.
28 pacotes não totalmente instalados ou removidos.
É preciso baixar 0 B/9.733 kB de arquivos.
Depois desta operação, 1.033 kB de espaço em disco serão liberados.
Você quer continuar? [S/n] s
Lendo logs de mudanças... Feito
Pré-configurando pacotes ...
(Lendo banco de dados ... 51737 files and directories currently installed.)
Preparing to unpack .../mariadb-server-core-10.0_10.0.28-0+deb8u1_amd64.deb ...
Unpacking mariadb-server-core-10.0 (10.0.28-0+deb8u1) over (10.0.20+maria-1~jessie) ...
dpkg: error processing archive /var/cache/apt/archives/mariadb-server-core-10.0_10.0.28-0+deb8u1_amd64.deb (-- unpack):
trying to overwrite '/usr/share/man/man1/innochecksum.1.gz', which is also in package mariadb-server-10.0 10. 0.20+maria-1~jessie
dpkg-deb: error: subprocess paste was killed by signal (Pipe quebrado)
dpkg: regarding .../mariadb-server-10.0_10.0.28-0+deb8u1_amd64.deb containing mariadb-server-10.0:
mariadb-server-10.0 conflita com mysql-server-core-5.5
mariadb-server-core-10.0 fornece mysql-server-core-5.5 e está presente e instalado.

dpkg: error processing archive /var/cache/apt/archives/mariadb-server-10.0_10.0.28-0+deb8u1_amd64.deb (--unpac k):
pacotes conflitantes - não instalando mariadb-server-10.0
Processing triggers for man-db (2.7.0.2-5) ...
Erros foram encontrados durante o processamento de:
/var/cache/apt/archives/mariadb-server-core-10.0_10.0.28-0+deb8u1_amd64.deb
/var/cache/apt/archives/mariadb-server-10.0_10.0.28-0+deb8u1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Responder à discussão

RSS

Parceiros

© 2017   Criado por Pedro Filho.   Ativado por

Badges - Divulgar  |  Relatar erro no site  |  Termos de serviço