MK-AUTH

[Resolvido] Mk-auth Parou de enviar e-mail com boleto mensal automaticamente

Boa Tarde Pedro, já faz uns 2 meses que o mkauth não consegue mais enviar mensalmente os e-mail com mensagens que já anexa os boletos automaticamente, daria pra ver se tem algum problema nesta rotina do mkauth ou seria algo só aqui?

Lembrando que se eu clicar em enviar no link em baixo do boleto o e-mail é enviado normalmente.

O Mkauth apenas não está enviando os e-mail mensalmente automaticamente.

Exibições: 657

Responder agora

Respostas a este tópico

Faz um backup e salve, depois faz um update manual e teste de novo amigo

foi feita alguma correção neste sentido? pois meu mkaut estava com atualização de 3 dias atrás.

Mas de qualquer forma fiz uma atualização novamente neste momento e gerei um boleto com vencimento de amanha pra ver se o mkauth envia um e-mail com boleto em anexo.

Deu certo?

Carlos Roberto Borges disse:

foi feita alguma correção neste sentido? pois meu mkaut estava com atualização de 3 dias atrás.

Mas de qualquer forma fiz uma atualização novamente neste momento e gerei um boleto com vencimento de amanha pra ver se o mkauth envia um e-mail com boleto em anexo.

o boleto é pra amanha dia 20 quando o mkauth irá enviar automaticamente aí saberei se tá funcionando.

Mas vc me pediu pra atualizar, e te perguntei se foi feito alguma correção neste sentido, pois meu mkauth já estava atualizado com a atualização de 3 dias atraz e continuava sem enviar os boletos.

Jonas Santos Suporte Mk-Auth disse:

Deu certo?

Tem mais de 60 dias que eu estou batendo nessa mesma tecla com o Jonas e ele insiste em dizer que o problema é conosco.

Carlos Roberto Borges disse:

o boleto é pra amanha dia 20 quando o mkauth irá enviar automaticamente aí saberei se tá funcionando.

Mas vc me pediu pra atualizar, e te perguntei se foi feito alguma correção neste sentido, pois meu mkauth já estava atualizado com a atualização de 3 dias atraz e continuava sem enviar os boletos.

Jonas até aqui o boleto que vence hj não foi enviado pelo mkauth veja os detalhes do cliente no print abaixo só consta o teste que enviei manualmente ontem mas o envio automático não foi:

amigos acabei de testar aqui na versão mais recente e todas as mensagens foram enviadas como mostra o print anexo, passei a ordem para o Jonas sempre que houver um update e alguém reclamar de erros no e-mail para fazer os mesmos testes e se estiver tudo ok solicitar para o usuário atualizar já que esse lance de e-mail somente é possivel fazer isso mesmo.

O envio de e-mail funciona em cima de um programinha para linux chamado Mutt, abaixo um exemplo de como o comando de envio funciona:

echo 'mensagem teste' | sudo mutt -F /etc/mk-auth/mutt.cfg -s 'assunto teste' pedrofilho@hotmail.com.br

com esse comando com sua senha correta já configurada dentro do webadmin no cadastro de servidores externos é enviado um e-mail para pedrofilho@hotmail.com.br com assunto: assunto teste e a mensagem: mensagem teste.

teste no terminal usando seus dados e veja se ocorre algum erro ...

Se vc usa o gmail tenta coloca ativado na url abaixo:

https://www.google.com/settings/security/lesssecureapps

Entendi Pedro, mas olhe o tópico que abri não reclamo que o mkauth não envia e-mail, não é esse o problema, ele envia mas só manualmente se eu clicar em enviar logo abaixo do boleto. ( inclusive fiz o teste que pediu e enviou normalmente a partir do putty com a linha de comando blz )

Porém o que reclamo é que o mkauth não está enviando os e-mail automáticos entende. ( como se alguma rotina de envio automático de e-mail não está acontecendo entende ? agora o envio de Sms automático alguns estão sendo enviados automaticamente normalmente mas já percebo que o envio de sms informando queo o cliente foi bloqueado este não vai automaticamente. )

Pra efeito de informação não uso servidores publico ( gmail, hotmail, bol, uol ... )

tenho meu próprio domínio e uso estrutura física da hospedagem Kinghosts.

São justamente estes e-mail do seu print de 10, 05 dias antes e depois bem como o do dia do vencimento que devem ser enviados automaticamente que não estão indo.



Pedro Filho disse:

O envio de e-mail funciona em cima de um programinha para linux chamado Mutt, abaixo um exemplo de como o comando de envio funciona:

echo 'mensagem teste' | sudo mutt -F /etc/mk-auth/mutt.cfg -s 'assunto teste' pedrofilho@hotmail.com.br

com esse comando com sua senha correta já configurada dentro do webadmin no cadastro de servidores externos é enviado um e-mail para pedrofilho@hotmail.com.br com assunto: assunto teste e a mensagem: mensagem teste.

teste no terminal usando seus dados e veja se ocorre algum erro ...

Se vc usa o gmail tenta coloca ativado na url abaixo:

https://www.google.com/settings/security/lesssecureapps

aqui rodou normal e-mail e celular

os testes que fiz foi nas mensagens automáticas também, é os mesmos comandos do cron em /etc/cron.d/email amigo e vc pode fazer Carlos, usa no terminal os comandos abaixo amigo, se houve títulos com vencimento de acordo ( exemplo: hoje dia 21/05, para mensagem 5 dias atraso vencimento é 16/05 ) com o comando certo irá enviar as mensagens:

/php -q /usr/local/mkauth/scripts/email.php
/php -q /usr/local/mkauth/scripts/email5.php
/php -q /usr/local/mkauth/scripts/email10.php
/php -q /usr/local/mkauth/scripts/email15.php
/php -q /usr/local/mkauth/scripts/email5antes.php
/php -q /usr/local/mkauth/scripts/email10antes.php



Carlos Roberto Borges disse:

Entendi Pedro, mas olhe o tópico que abri não reclamo que o mkauth não envia e-mail, não é esse o problema, ele envia mas só manualmente se eu clicar em enviar logo abaixo do boleto. ( inclusive fiz o teste que pediu e enviou normalmente a partir do putty com a linha de comando blz )

Porém o que reclamo é que o mkauth não está enviando os e-mail automáticos entende. ( como se alguma rotina de envio automático de e-mail não está acontecendo entende ? agora o envio de Sms automático alguns estão sendo enviados automaticamente normalmente mas já percebo que o envio de sms informando queo o cliente foi bloqueado este não vai automaticamente. )

Pra efeito de informação não uso servidores publico ( gmail, hotmail, bol, uol ... )

tenho meu próprio domínio e uso estrutura física da hospedagem Kinghosts.

São justamente estes e-mail do seu print de 10, 05 dias antes e depois bem como o do dia do vencimento que devem ser enviados automaticamente que não estão indo.

Pedro eu nao sei quanto ao amigo carlos!

Mais eu fiz o teste aqui executando o script pra 5 dias de atrazo e nao foi enviado o e-mail.

Coloquei boletos vencendo dia 15, 16 e 17/05, rodei o script e nada. Antes de alguns meses rodava normalmente.

Pedro Filho disse:

os testes que fiz foi nas mensagens automáticas também, é os mesmos comandos do cron em /etc/cron.d/email amigo e vc pode fazer Carlos, usa no terminal os comandos abaixo amigo, se houve títulos com vencimento de acordo ( exemplo: hoje dia 21/05, para mensagem 5 dias atraso vencimento é 16/05 ) com o comando certo irá enviar as mensagens:

/php -q /usr/local/mkauth/scripts/email.php
/php -q /usr/local/mkauth/scripts/email5.php
/php -q /usr/local/mkauth/scripts/email10.php
/php -q /usr/local/mkauth/scripts/email15.php
/php -q /usr/local/mkauth/scripts/email5antes.php
/php -q /usr/local/mkauth/scripts/email10antes.php

Responder à discussão

RSS

Parceiros

© 2017   Criado por Pedro Filho.   Ativado por

Badges - Divulgar  |  Relatar erro no site  |  Termos de serviço