MK-AUTH

Ola Pedro.

Tenho uma maquina virtual HiperV com o mkauth64 na versão 4.113 instalado do qual comecei a ter problemas na geração de boletos a automático. Então pensei em reparar o banco mas ao executar o reparo aparece mensagem "echo: erro de gravação: Pipe quebrado", porém isso não ocorre antes de colocar o backup e também não ocorre com outros backups de outras empresas.

Efetuei a compra de outra licença achando ser porque estou usando a licença de quando era 32b e na versão antiga.

Nas versões anteriores funciona o reparo mas ainda sem gerar os boletos automaticos.

Segue um anexo.

Exibições: 64

Anexos

Responder agora

Respostas a este tópico

nas ultimas atividades esta dando isso " tem dados invalidos para envio ao GerenciaNet "

não aparece o nome do cliente nessa mensagem ?

DAVID STOCCO JUNIOR disse:

nas ultimas atividades esta dando isso " tem dados invalidos para envio ao GerenciaNet "

quando solicito o reparo via ssh a frase se repete umas 10x em sequida inicia o repare clientepor cliente....mas quando aparece o nome, aparece em seguida esta mensagem ao lado do nome tamebem e logo vao pro proximo...isso se repete em todos.

Pedro Filho disse:

não aparece o nome do cliente nessa mensagem ?

DAVID STOCCO JUNIOR disse:

nas ultimas atividades esta dando isso " tem dados invalidos para envio ao GerenciaNet "

Achei o problema.

Para o mkbot gerar um boleto para um cliente tem que respeitar as seguintes regras

-a data de vencimento do boleto nao pode ser inferior que a data de amanha.

-não pode haver outro boleto na gerencianet do mesmo mes de vencimento.

-deve ja ter um boleto criado do mes passado (senao ele tenta criar)

Ex: (cliente fulano vencimento mensal 10) hoje 11/04...se não haver um boleto do mês 03, o mkbot vai tentar gerar um boleto para 10/03 e nao vai dar...se vc tentar criar um boleto para mes 03 nao vai dar certo e vc vai ter que criar um boleto para 12/04.

Entao o mkbot so vai criar o boleto em 10/05.



Pedro Filho disse:

não aparece o nome do cliente nessa mensagem ?

DAVID STOCCO JUNIOR disse:

nas ultimas atividades esta dando isso " tem dados invalidos para envio ao GerenciaNet "

sem contar que se o cliente pagar o boleto atrazado o mkbot ja nao gera o boleto seguinte...e se nao ha boleto no mes seguinte os demais em cascata nao sao gerados.

DAVID STOCCO JUNIOR disse:

Achei o problema.

Para o mkbot gerar um boleto para um cliente tem que respeitar as seguintes regras

-a data de vencimento do boleto nao pode ser inferior que a data de amanha.

-não pode haver outro boleto na gerencianet do mesmo mes de vencimento.

-deve ja ter um boleto criado do mes passado (senao ele tenta criar)

Ex: (cliente fulano vencimento mensal 10) hoje 11/04...se não haver um boleto do mês 03, o mkbot vai tentar gerar um boleto para 10/03 e nao vai dar...se vc tentar criar um boleto para mes 03 nao vai dar certo e vc vai ter que criar um boleto para 12/04.

Entao o mkbot so vai criar o boleto em 10/05.



Pedro Filho disse:

não aparece o nome do cliente nessa mensagem ?

DAVID STOCCO JUNIOR disse:

nas ultimas atividades esta dando isso " tem dados invalidos para envio ao GerenciaNet "

Responder à discussão

RSS

Parceiros

© 2018   Criado por Pedro Filho.   Ativado por

Badges - Divulgar  |  Relatar erro no site  |  Termos de serviço