MK-AUTH

Usava Hotspot, dai passei para PPPoE, mas deu muito problemas, dai passei usar IP x MAC, e esta todo funcionando tao bem,mas tao bem. que para ser perfeito só precisava de uma coisinha.
Eu precisava que ao alterar um cliente no ramal X ele executasse um script no MK desse ramal ou adicionasse o IP e MAC desse cliente na tabela ARP.

Tipo assim, atualmente o mk-auth ele envia por ssh o IP e MAC para o leases do servidor DHCP do ramal, então, queria também que enviasse o IP e MAC para a tabela ARP desse ramal. Só isso que estou precisando para meu IP x MAC funcionasse automaticamente. será que tem como?

Atualmente apos qualquer atualizaçao no cadastro do cliente tenho que executar manual este script para excluir e puxar toda a lista de ARP do mk-auth.

#==========================
:global IPMKAUTH "172.31.255.2";
:global KEY "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxx";
:global RAMAL "172.31.255.22";
:global done "";
/tool fetch mode=http url="https://$IPMKAUTH/mkt/arp.php\?key=$KEY&ramal=$RAMAL" src-path=mkt_arp.php dst-path=mkt_arp.rsc;
:set done "true";

:if ( [/file find name=mkt_arp.rsc] != "" ) do={
:log warning "Importando ARP";
/import mkt_arp.rsc;
/file remove mkt_arp.rsc;
}

Exibições: 242

Responder agora

Respostas a este tópico

irei fazer teste e se funcionar irei colocar...

Obrigado Pedro...

Pedro, vc poderia postar ou me enviar o Script PHP que vc utiliza no opt/mk-auth/mkt/arp.php e queues.php , tentei baixar do meu mk-auth para criar um novo e tomar de referencia o que ja existe, mas parece estar codificado. Meu intuito não é alterar nada, e sim criar um novo tomando esse de referencia.

Muito Obrigado.

Pedro Filho disse:

irei fazer teste e se funcionar irei colocar...

Pedro. Não tem como fornecer esses arquivos? Caso nao seja possivel, precisso saber para achar outra solução...

consegui criar um Arquivo PHP para puxar as informações dos clientes por INTERFACE como preciso que estejam formatadas.
agora, como faço para puxar a velicidade de cada cliente para adicionar no Queue? 
Pode me dar uma luz ?

o que esta faltando aqui? 
para preencher as velocidades do cliente?

bom dia Pessoal.

Queria agradecer o Anderson, boa gente como todo Mineiro que me ajudo no script. Vou postar aqui por se alguém precisar, sao uns scripts PHP simples, um vitoria para mim que nao entende nada de PHP e acredito tenha alguma coisa para melhorar, no meu caso já atende...

php.rar

Boa tarde pessoal, preciso de alguém que saiba como fazer funcionar autenticação IP x MAC no mkauth preciso implantar na minha rede e não quero migrar para o PPPoE.

Responder à discussão

RSS

parcerias

© 2019   Criado por Pedro Filho.   Ativado por

Badges - Divulgar  |  Relatar erro no site  |  Termos de serviço