MK-AUTH

Clientes que estão bloqueados no MK-Auth estão navegando normalmente (PPPoE)

Pessoal, queria saber como configurar corretamente uma regra de corte, pois já coloquei uma e a página de corte apareceu para todos os clientes, até para os que estavam sem pendência, gostaria que aparecesse apenas para os que estão com pendência!!

Exibições: 114

Responder agora

Respostas a este tópico

http://mk-auth.com.br/forum/topics/nat-efetivo-para-bloqueio-mkauth

/ip firewall nat


add action=dst-nat chain=dstnat comment="PG CORTE HTTPS" dst-address=!172.31.255.2 dst-port=443 protocol=tcp src-address-list=pgcorte to-addresses=172.31.255.2 to-ports=\
445
add action=dst-nat chain=dstnat comment="PG CORTE PPPoE" dst-address=!172.31.255.2 protocol=tcp src-address-list=pgcorte to-addresses=172.31.255.2 to-ports=85
add action=dst-nat chain=dstnat comment="PG CORTE PPPoE" dst-address=!172.31.255.2 protocol=udp src-address-list=pgcorte to-addresses=172.31.255.2 to-ports=85

Caro,

Poderia me informar se  onde menciona o outro topico não seria mais simples mencionar que esta bloqueando a 0-65535



Sóstenes L. Teixeira disse:

http://mk-auth.com.br/forum/topics/nat-efetivo-para-bloqueio-mkauth

/ip firewall nat


add action=dst-nat chain=dstnat comment="PG CORTE HTTPS" dst-address=!172.31.255.2 dst-port=443 protocol=tcp src-address-list=pgcorte to-addresses=172.31.255.2 to-ports=\
445
add action=dst-nat chain=dstnat comment="PG CORTE PPPoE" dst-address=!172.31.255.2 protocol=tcp src-address-list=pgcorte to-addresses=172.31.255.2 to-ports=85
add action=dst-nat chain=dstnat comment="PG CORTE PPPoE" dst-address=!172.31.255.2 protocol=udp src-address-list=pgcorte to-addresses=172.31.255.2 to-ports=85

Exibir pagina de corte usando Radius LIST ou SSH:

/ip firewall filter
add action=drop chain=forward comment=CORTE dst-port=!53 protocol=udp src-address-list=pgcorte
add action=drop chain=forward comment=CORTE dst-port=!80,85,443,445 protocol=tcp src-address-list=pgcorte

/ip firewall nat
add action=dst-nat chain=dstnat comment=CORTE_HTTPS dst-address=!172.31.255.2 dst-port=443 protocol=tcp src-address-list=pgcorte to-addresses=172.31.255.2 to-ports=445
add action=dst-nat chain=dstnat comment=CORTE_HTTP dst-address=!172.31.255.2 dst-port=80 protocol=tcp src-address-list=pgcorte to-addresses=172.31.255.2 to-ports=85

Exibir pagina de corte usando Radius Pool:

/ip pool
add name=pgcorte ranges=10.3.0.2-10.3.3.254

/ip address
add address=10.3.0.1/22 broadcast=10.3.3.255 network=10.3.0.0 comment=CORTE interface=porte

/ip firewall filter
add action=drop chain=forward comment=CORTE dst-port=!53 protocol=udp src-address=10.3.0.2-10.3.3.254
add action=drop chain=forward comment=CORTE dst-port=!80,85,443,445 protocol=tcp src-address=10.3.0.2-10.3.3.254

/ip firewall nat
add action=dst-nat chain=dstnat comment=CORTE_HTTPS dst-address=!172.31.255.2 dst-port=443 protocol=tcp src-address=10.3.0.2-10.3.3.254 to-addresses=172.31.255.2 to-ports=445
add action=dst-nat chain=dstnat comment=CORTE_HTTP dst-address=!172.31.255.2 dst-port=80 protocol=tcp src-address=10.3.0.2-10.3.3.254 to-addresses=172.31.255.2 to-ports=85

PROBLEMAS E SOLUÇÕES:

se vc usa a pagina de corte por radius, uma forma de vc saber se seu cliente realmente esta bloqueado no radius e clica no link informações que tem abaixo do nome do cliente e na janela que abre na parte de radius veja se tem os parametros Mikrotik-Address-List / Framed-Pool como na imagem abaixo, se tem então o erro com certeza é no MikroTik por isso depois do login, veja se o ip do cliente bloqueado entra no address-list/pool do MikroTik:

se vc usa a pagina de corte por ssh, uma forma de vc saber se seu cliente realmente esta bloqueado é ver se na address-list o ip do cliente aparece, se não aparece veja se não é falha na comunicação ssh. Para testar a comunicação ssh agora o sistema envia uma regra desabilitada para o filter do MikroTik, se gravar a regra é pq esta ok...

nas duas formas de bloqueio é preciso colocar a regra de redirecionamento para pagina de corte acima de todas as outras no nat do MikroTik e nas configurações de profile de hotspot do MikroTik é preciso deixar a opção transparet proxy desativada.

TOPICOS QUE PODEM AJUDAR:

Clientes bloquados nao acessam hotspot - MK-AUTH

A regra de Corte mudou na 4.90, mas quem muda o ip do cliente com i...

Bloqueio automatico - pppoe - MK-AUTH

Bloqueando Clientes Via Radius Mangle PPPoe Ips válidos sem Nat - M...

Problemas com a pagina de bloqueio! - MK-AUTH

Liberar site pra cliente bloqueados - MK-AUTH

Regra de corte via mangle 03 interfaces hotspot - MK-AUTH

REGRA PGCORTE COM THUNDERCACHE 7 - MK-AUTH

Responder à discussão

RSS

TheLinuxF

© 2018   Criado por Pedro Filho.   Ativado por

Badges - Divulgar  |  Relatar erro no site  |  Termos de serviço