MK-AUTH

Pedro estou migrando meus clientes para pppoe, mas hoje percebi q meus clientes bloqueados no sistema nem consegue se conectar, da falha . ai se desbloqueio conecta normal....

Exibições: 434

Responder agora

Respostas a este tópico

Alguém... 

se vc usa a pagina de corte por radius, uma forma de vc saber se seu cliente realmente esta bloqueado no radius e clica no link informações que tem abaixo do nome do cliente e na janela que abre na parte de radius veja se tem os parametros Mikrotik-Mark-Id ou Framed-Pool (clientes hotspot) ou Mikrotik-Address-List (clientes pppoe) como na imagem abaixo, se tem então o erro com certeza é no mikrotik por isso depois do login, veja se o cliente bloqueado aparece no mangle do mikrotik (hotspot) ou veja se o ip do cliente bloqueado entra no address-list do mikrotik (pppoe):

 

 

se vc usa a pagina de corte por ssh, uma forma de vc saber se seu cliente realmente esta bloqueado é ver se na address-list o ip do cliente aparece, se não aparece veja se não é falha na comunicação ssh, clique no link informações da pagina de ramais mikrotik e veja se aparece os dados como na imagem abaixo, caso os dados sejam mostrados com sucesso então a razão do bloqueio por ssh não funcionar é pq o cliente não tem um ip definido no cadastro dele ou nunca tenha se conectado ao provedor.

 

 

nas duas formas de bloqueio é preciso colocar a regra de redirecionamento para pagina de corte acima da regra de nat para o proxy no nat do mikrotik e nas configurações de profile de hotspot do mikrotik é preciso deixar a opção transparet proxy desativada.

 

veja abaixo as regras atuais para exibir a pagina de corte com radius ou ssh:

 

Para todos os clientes:

/ip firewall nat

add action=dst-nat dst-address=!172.31.255.2 chain=dstnat comment="PG CORTE" disabled=no protocol=tcp src-address-list=pgcorte to-addresses=172.31.255.2 to-ports=85

Para hotspot com radius (pool):

/ip pool

add name=pgcorte ranges=10.3.0.2-10.3.3.254

/ip address

add address=10.3.0.1/22 broadcast=10.3.3.255 network=10.3.0.0 interface=Placa do clientes

/ip firewall nat

add action=dst-nat dst-address=!172.31.255.2 chain=dstnat comment="PG CORTE" disabled=no protocol=tcp src-address=10.3.0.2-10.3.3.254 to-addresses=172.31.255.2 to-ports=85

Para hotspot com radius (mangle):

/ip firewall mangle

add chain=prerouting action=jump comment="PG CORTE" jump-target=hotspot

/ip firewall nat

add chain=hotspot comment="PG CORTE" packet-mark=bloqueado protocol=tcp action=dst-nat to-addresses=172.31.255.2 to-ports=85

Eduarlei Avelar disse:

Alguém...

Pedro bloqueado ele esta, mas o problema que nem consegue fazer autenticação, então não aparece tela de bloqueio. 

Anexos

tbm estou com um de meus servidores assim

Claudio entre no financeiro do cliente. Marque a opção (Cliente recebe pagina de Corte, Cliente Recebe Pagina de Aviso). SIM

Cláudio Lemes disse:

tbm estou com um de meus servidores assim

Boa noite pedro

depois de atualizar o servidor e o MK-AUTH meu clientes bloqueados ficam dando erro de autenticação..

MK-AUTH 32 BITS 4.113

freeradius: FreeRADIUS Version 2.1.12, for host i486-pc-linux-gnu, built on Aug 25 2017 at 17:15:53

obrigado pela informação já estava assim depois que reinstalei o sistema voltou a funciona, creio que erar algum bug ou alguma dependência não foi devidamente atualizada.



Martz Informatica disse:

Claudio entre no financeiro do cliente. Marque a opção (Cliente recebe pagina de Corte, Cliente Recebe Pagina de Aviso). SIM

Cláudio Lemes disse:

tbm estou com um de meus servidores assim

Responder à discussão

RSS

Parceiros

© 2018   Criado por Pedro Filho.   Ativado por

Badges - Divulgar  |  Relatar erro no site  |  Termos de serviço